"WARNING: The following essential packages will be removed." when upgrading to Debian 6.0

Issue

When performing the upgrade to Debian 6.0 the following may be seen when running the dist-upgrade:

# apt-get dist-upgrade
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Calculating upgrade... Done
The following packages will be REMOVED:
  apt apt-utils apt-xapian-index aptitude binutils ffmpeg g++ g++-4.3 gcc gcc-4.3 gettext-base ghostscript groff-base
  gs-common imagemagick lftp libavcodec52 libavdevice52 libavfilter0 libavformat52 libboost-iostreams1.42.0 libcwidget3
  libdatrie0 libdirac-encoder0 libdjvulibre21 libept1 libgc1c2 libgomp1 libgraphviz4 libgs8 libilmbase6 libmagick10
  libopenexr6 libpcre3-dev libpcrecpp0 libsigc++-2.0-0c2a libstdc++6 libstdc++6-4.3-dev libxapian15 libxapian22
  libxcb-xlib0 lzma man-db mysql-client mysql-client-5.0 mysql-server mysql-server-5.0 nmap python-apt python-xapian re2c
  reportbug spamass-milter tasksel tasksel-data telnet w3m wordpress zoneminder
The following NEW packages will be installed:
  dash db4.8-util dbus diffutils dmsetup insserv install-info isc-dhcp-client isc-dhcp-common libavahi-client3
  libavahi-common-data libavahi-common3 libbind9-60 libbsd0 libcdt4 libdatrie1 libdbus-1-3 libdjvulibre-text libdns69
  libevent-1.4-2 libfile-copy-recursive-perl libgpgme11 libgraph4 libgvc5 libisc62 libisccc60 libisccfg62 libjbig2dec0
  libjs-cropper libjs-jquery liblqr-1-0 libltdl7 liblua5.1-0 liblwres60 libmpfr4 libnfnetlink0 libonig2 libopts25
  libpathplan4 libpth20 libpython2.6 libqdbm14 libtokyocabinet8 libxdot4 libyaml-syck-perl os-prober php-gettext
  php5-suhosin shared-mime-info tsconf
The following packages have been kept back:
  cpp cpp-4.3 gcc-4.3-base grub grub-common libgcc1
The following packages will be upgraded:
  bash bind9 bind9-host bind9utils dhcp3-client dhcp3-common diff djvulibre-desktop dnsutils info iptables
  libapache2-mod-php5 libcups2 libcupsimage2 libdate-manip-perl libdevmapper1.02.1 libedit2 libgtk2.0-0 libgtk2.0-bin
  libpango1.0-0 librsvg2-2 libthai-data libthai0 libts-0.0-0 libx11-6 libxcb1 libxi6 mutt nfs-common ntp ntpdate
  openssh-client openssh-server php5 php5-cli php5-common php5-curl php5-gd php5-mcrypt php5-mysql php5-sqlite sasl2-bin
  sysv-rc update-inetd vim-common vim-nox vim-runtime vim-tiny
WARNING: The following essential packages will be removed.
This should NOT be done unless you know exactly what you are doing!
  apt libstdc++6 (due to apt)
48 upgraded, 50 newly installed, 59 to remove and 6 not upgraded.
Need to get 36.3 MB of archives.
After this operation, 197 MB disk space will be freed.
You are about to do something potentially harmful.
To continue type in the phrase 'Yes, do as I say!'
^C

Resolution

It appears two unstable packages are installed:

- gcc-4.4-base 4.4.5-10
- libstdc++6 4.4.5-10

Check dependency issues:
# apt-get --dry-run -o Debug::pkgDepCache::AutoInstall=1 -o Debug::pkgProblemResolver=1 dist-upgrade
...


Downgrade these two packages to 4.4.5-8:
# wget http://ftp.us.debian.org/debian/pool/main/g/gcc-4.4/libstdc++6_4.4.5-8_i386.deb

# wget http://ftp.us.debian.org/debian/pool/main/g/gcc-4.4/gcc-4.4-base_4.4.5-8_i386.deb

# dpkg -i libstdc++6_4.4.5-8_i386.deb gcc-4.4-base_4.4.5-8_i386.deb 
dpkg: warning: downgrading libstdc++6 from 4.4.5-10 to 4.4.5-8.
(Reading database ... 57440 files and directories currently installed.)
Preparing to replace libstdc++6 4.4.5-10 (using libstdc++6_4.4.5-8_i386.deb) ...
Unpacking replacement libstdc++6 ...
dpkg: warning: downgrading gcc-4.4-base from 4.4.5-10 to 4.4.5-8.
Preparing to replace gcc-4.4-base 4.4.5-10 (using gcc-4.4-base_4.4.5-8_i386.deb) ...
Unpacking replacement gcc-4.4-base ...
Setting up gcc-4.4-base (4.4.5-8) ...
Setting up libstdc++6 (4.4.5-8) ...

References

Products

Debian GNU/Linux 5.02 (lenny)
Debian GNU/Linux 6.0.1 (Squeeze)

Created: 4th April 2011
Updated: 4th April 2011


© 2005-2020 Jamie Morrison